It Seems that Every Time I Fix Something, Something Else is Still Broken

It’s been an interesting lab today. I got a working microphone from a classmate, and hooked that up with one of the led strips that my professor told me was fixed, only to have a lot of trouble getting the led strip to work. It turns out the jumper cables I was using to connect the led strip to the Arduino were pretty unreliable, so I soldered wires onto the strip that would more easily plug into the Arduino, and tried to move forward from there. When I plugged everything into the board to do a finall test before building the suspenders I had intended to build last week, neither my laptop nor the mac I’d been using in the lab would upload the code. They both even rejected the simplest Blink sample code for a few minutes, but after waiting a bit, I was able to upload code eventually, though both computers will just spontaneously quit. I sat working with one of my TAs, Nikki, trying to figure this out, but we got nowhere. I’m still not able to get the leds to light up from my sample code. I think I will begin building the suspenders themselves and schedule a meeting with my professor to sort out the code. 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s